SQL: Resolve “Oracle JRE 7 Update 51 (64-bit) or Higher is Required “


Introduction

This blog describes how to resolve the above-mentioned error in title what occurs while installing SQL server.

Getting Started

While installing SQL server 2016 or above version, most of developer getting error message “Oracle JRE 7 Update 51 (64-bit) or Higher is Required ", but don’t worry this is very minor error and can be resolved within few minutes.


Before directly going to resolve this error, let’s discuss about the reason behind this. The reason behind of this error is that while installing SQL server developer selects ‘PolyBase Query Service for External Data’ and the Oracle JRE 7 updates is not available in server.

Solution of "Oracle JRE 7 Update 51 (64-bit) or Higher is Required" Error Message:


The solution of this error is that if ‘PolyBase Query Service for External Data’ feature is not required then go back the feature selection window and unselect this feature or if required then install the Oracle JRE 7 Update into your machine or server.

About PolyBase Query Service for External Data:


PolyBase is a technology that accesses data outside of the database via the t-sql language. In SQL Server 2016, it allows you to run queries on external data in Hadoop or to import/export data from Azure Blob Storage. Queries are optimized to push computation to Hadoop. In Azure SQL Data Warehouse, you can import/export data from Azure Blob Storage and Azure Data Lake Store.

Installing Oracle JRE 7 Update 51 (64-bit):


The Oracle JRE 7 Update belongs to Java SE JDK, to install Oracle JRE 7 Update into your server or machine download the Java SE JDK directly for Oracle server and install it.

Thanks
Kailash Chandra Behera


No comments:

Post a Comment